Knowledge Base

What is the minimum firmware version needed on my Kestrel 5700 or 5700 Elite to use the HUD?

You will need to update your Kestrel firmware version to 1.35 (or higher) in order to use the HUD. You can update your Kestrel firmware through the Kestrel LiNK Ballistics for Android or iOS apps